Toyota Tacoma Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1 (Edited by Moderator)
Here are my pics, please excuse my really dirty truck.
I did take the opportunity to clean the dead bugs out of the radiators, and spray all the silver stuff behind the grill black.



I posted details here on 'the other place'

I used MetalCast, and it goes on well. I destroyed one emblem because I tried sanding it first as instructed... it looked like crap.

The only problem I have is durability, as I get pits, missing paint chips, in the emblem, and have to repaint it every few months. Although it is rather quick and easy, 1 minute to remove all the old with Acetone, and another 30 to spray. Next time I may try a shot of acrylic clear I have laying around over the top. Overall I think it looks good.

I also did all the Toyota logos on the hubs on the rims, makes a big difference in appearance. These show no sign of wear. (sorry no pictures of these)
 

·
Registered
Joined
·
5,471 Posts
are those emblems on the hub just clipped on..or are they glued on...I would like to paint them as well. I hate chrome
 

·
Registered
Joined
·
249 Posts
Discussion Starter #3 (Edited by Moderator)
are those emblems on the hub just clipped on..or are they glued on...I would like to paint them as well. I hate chrome
There are pushed in and then sealed by melting over the top, a few seconds with a dremel took then right off, I then just glued them back on, lasted 8K miles without an issue.
 

·
Registered
Joined
·
5,471 Posts
Well my center cap emblems are now Black pearl....looks alot better
 
1 - 7 of 7 Posts
Top