Toyota Tacoma Forum banner

1 - 20 of 43 Posts

·
Registered
Joined
·
105 Posts
I have gone 11.2 @84 mph. had to let of when shifting to 3rd gear nitros stuck open( I only use nitrous for spool up)= wheel spin. Maybe better luck next time, hopefully.

How is your rear setup, i mean do you have a four link or something like that?

Viking.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #15
I use a 1994 ford explorer rear end factory w/dics brakes bolts right in (exp for making an e/brake cable mount. I put eaton posi unit in 373gears (changing to as spool).I put comeng preload bars on and removed the helper spring. I also made the rear leaf spring mount a slider.Tires 28/10.5 MT. I pull 1.4 60ft with the stick shift.

The video of 9sec truck is not a tacoma and it has a th400chevy trans.
But it is the fastest toyota (I think street truck) around right now.

Most the classes that I run won't let you run in a class if you have out of make drive trans (nissan,chevy, ford in a toyota)

I still use the 7mgte or 1jz trans with TRD 3puck clutch. I plan on putting the supra 6 spd in when I brake this tranny (broken two to date).

It's funny you said 3rd gear you had to let off I have had the same problem I hit 3rd and I have almost turn the truck sidways 3times now thats may resone for the spool. A posi unit can't hold up to full power.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #16
It would be easy to go really fast with the th400 trans (put a 3800stall, rev manual valve body w/transbrake) Thats what we put in all the supra's with big power.
But i don't wont to go there yet.
I can get away with my rear end but the trans is a different thing.
 
1 - 20 of 43 Posts
Top