Toyota Tacoma Forum banner
1 - 3 of 3 Posts

·
Registered
99 Tacoma 4WD 3.4L
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everyone!

Hello there Taco Owners!

My problem started after power washing some parts of my engine. I had a lot of oil and grime under my oil pan and on my skid plates so I took the plates off and went to town on it from below and also power washed most of the top of the engine due to a lot of dirt and dust. But afterwards my turn signal 10A and horn/hazards 15A fuses keep blowing every time I try to use them.

I can use my left turn signal fine after replacing the fuse but as soon as I use my right signal it blows immediately every time. Doesn't matter if I am moving or parked. The left signal seems to work just fine and will only stop working once the right signal blows the fuse. The hazards work only for about 5 to 10 seconds if on constantly and then the fuse blows as well. The horn/hazards seem to hold from blowing the fuse longer if the turn signal fuse is still good. When I use the hazards the green arrow lights on my display kind of flicker and blink with a stutter but when I use my left turn signal the green arrow light blinks normal and steady. When I use the right signal, boom it blows the fuse immediately?

I have inspected the turn signal lights themselves and I don't see any signs of bad bulbs or damage. I have seen other people suggest water intrusion into one of the bulbs but it's strange that the hazards don't immediately short out when engaged. I am not seeing any exposed or damaged wires and I had no problems with these devices the day before.

Any help or ideas would be greatly appreciated. As you all know, these electrical gremlins and be quite the pain in the a** haha! Thank you in advance for any advice!

99 Tacoma
4WD Automatic
3.4L
 

·
Mambeau / Admin
Joined
·
48,232 Posts
Welcome to CT!

What else (besides the engine) did you spray / wash?

Were there any signs of water intrusion through the floorboard or behind / under the dash?

Are there any other electrical components that are misbehaving?
 

·
Mambeau / Admin
Joined
·
48,232 Posts
In the mean time, here (attached) is the 1999 turn signal / hazard lights wiring diagram.

I'm also attaching the 1999 wiring connector / ground points diagrams. I recommend double-checking the ground point EA on the left fender.

I'm also including the 1999 general electrical parts locations (PartsLocs) diagram. I recommend double-checking the J9 / J10 connection at the fuse / relay box at the left fender.
 

Attachments

1 - 3 of 3 Posts
Top