Toyota Tacoma Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have replaced the battery. Checked all the fuses and replaced the ignition relay under the hood. Can anyone tell me why my Toyota all of a sudden will not start. When you turn the key the dash,radio,etc all light up but it will not turn over.
 

·
Mambeau / Admin
Joined
·
47,972 Posts
If the instrument panel lights up but there's no cranking the most likely suspects are:

  • bad Park / Neutral Position Switch (automatic tranny)
  • bad Clutch Start Switch (manual tranny)
  • bad Starter Relay

... assuming the starter's good and it's not a wiring fault somewhere. I also assume the "ignition relay" you replaced was the EFI Relay.

Here (attached is the 2005 starter circuit wiring diagram.
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
If parking sensor was bad would it read correctly on the dash lights when I switch from p to n? Also the relay that I changed was the one under the hood labeled start relay. Please advise where to go from here as your help is much appreciated.
 

·
Mambeau / Admin
Joined
·
47,972 Posts
OK - if it's the Starter Relay you replaced, then that probably isn't the fault.

Yes - if the auto tranny gear indicator lamps are shifting as you shift gears that means the Park / Neutral Position Switch is OK.

Double check the big ALT, AM1 and AM2 fuses.

If they're all good, I'd have to think it's either the ignition switch, the starter or some wiring fault somewhere.
 

·
Waxed to Perfection
Joined
·
5,659 Posts
I have replaced the battery. Checked all the fuses and replaced the ignition relay under the hood. Can anyone tell me why my Toyota all of a sudden will not start. When you turn the key the dash,radio,etc all light up but it will not turn over.
If parking sensor was bad would it read correctly on the dash lights when I switch from p to n? Also the relay that I changed was the one under the hood labeled start relay. Please advise where to go from here as your help is much appreciated.
From the positive battery post. You will find a smaller wire that goes to the black relay box mounted on inner fender behind battery. That smaller wire connects to the engine side of the box and supplies power to all the relays etc. Mine, corroded at the terminal on the box connector. One I replaced with a new wire. No more issues. Good luck.
 
  • Like
Reactions: Enola Gaia
1 - 5 of 5 Posts
Top