Toyota Tacoma Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
Hi all,

about 3 weeks ago i started having trouble with the key not coming out of the ignition. when i turn off the truck, the key will not go into the off position and i cannot pull the key out. first i went and dug out my spare key which has nice sharp cut edges (old key edges were rounded and worn). but that was not the problem. next i replaced the ignition cylinder but im still having the same problem. Right after i replaced the cylinder...the truck would not start. when i try to start, i just get a click. all accessories work just fine. i thought maybe i killed the battery...battery was almost 5 yrs old so i replaced it with a new one. Still get just a click with new battery. So now i have 2 issues. I'm now thinking it has something to do with the gear shifter. If i play with the shifter... moving it in/out of all gears... eventually the key will turn to the off position and come out. maybe i'm wrong.

Any ideas would be great.
thanks in advance

Cadman
 

·
Mambeau / Admin
Joined
·
47,910 Posts
First - have you checked the 7.5A STA (Starter) fuse?

Moving beyond that ...

My first guess is that the Park / Neutral Position Switch is bad / whatever, so that the Starter Relay isn't getting activated because the signal for it being in P or N isn't happening. This could be the result of an electrical or wiring fault somewhere in the circuit(s).

Your PreRunner has the ECT (Electronically Controlled Transmission), which involves additional wiring / components for the tranny control. I suppose it might be that a fault somewhere in the ECT circuits could screw with the P / N signal or somehow otherwise prevent it from starting.
 

·
Mambeau / Admin
Joined
·
47,910 Posts
Here (attached) are the 2004 4-cylinder starting and ECT circuit wiring diagrams.
 

Attachments

  • Like
Reactions: Dirtboy

·
Registered
Joined
·
152 Posts
Discussion Starter · #5 ·
thanks for the replies... checked fuse. its good. i think if it were blown i would not get anything from the starter. but i'm getting a single CLICK when i try to start. gonna research on how to check the position switch and let you know what i find out.
 
1 - 5 of 5 Posts
Top