Toyota Tacoma Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Kind of odd request I know. I have been chasing a knock sensor code for weeks now and during my "diagnosis" I noticed that there isn't any shielding around the knock sensor wires at the ECM... At this point I am thinking that the wires are picking up noise and causing my false codes.

So, I am in need of a picture (or a few) of an untouched harness so I can see where there should be shielding. (Around all the wires? just the knock sensor wires?)

I have a 98 4Runner, the knock sensor wires are in connector "B", wire colors are Black and Gray in the center of the connector. (B14 Gray, B15 Black)

Also, where can I buy shielding?

:thanks:
 

·
Mambeau / Admin
Joined
·
47,578 Posts
You're right - that's an odd request ... :evil:

But seriously ... :thinking:

Here (attached) is the relevant part of the 96 - 02 4Runner engine control wiring diagram. The only thing it tells me is that the wiring harness is shielded on both sides of the EB1 connector.


This connector is listed as:

Sensor Wire and Engine Wire (Front Side of Cylinder Head Cover Right)

I have no idea what one would use to add shielding. To the best of my recollection no one's ever asked about adding shielding before.
 

Attachments

·
Registered
Joined
·
64 Posts
Discussion Starter #3 (Edited)
You're right - that's an odd request ... :evil:

But seriously ... :thinking:

Here (attached) is the relevant part of the 96 - 02 4Runner engine control wiring diagram. The only thing it tells me is that the wiring harness is shielded on both sides of the EB1 connector.


This connector is listed as:

Sensor Wire and Engine Wire (Front Side of Cylinder Head Cover Right)

I have no idea what one would use to add shielding. To the best of my recollection no one's ever asked about adding shielding before.


I know there is shielding on the harness from the EB1 to the knock sensors, but I am wondering if the other shielding shown in the diagram is on the ECM connector side as it enters/exits the ECM. I recently installed/wired an FIC6 but I cannot remember for sure if there was shielding there, I don't recall removing any but the wiring diagram makes it look like there should be some there. That is why I am hoping to find someone with a picture of the untouched wiring.
 

·
Mambeau / Admin
Joined
·
47,578 Posts
I'm not sure anyone here would be likely to have a picture of 4Runner wiring harnesses. Have you asked over at YotaTech (which specializes in 4Runners)?

The diagram appears to indicate 2 separate pairs of shielded wiring - 2 each on either side of the EB1 connector. On the knock sensor side the shielding is tied in at the E4 juncture. On the ECM side the shielding is tied into the I20 and E1 junctures. In other words, the 2 pairs of shielding tie into the overall harness at different places.

The Toyota Wire Harness Repair Manual doesn't even mention shielding at all.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
I was able to acquire some pictures of an untouched harness and from what I could see, it didn't look like the shielding on the ECM side was visible. It must be either near the firewall more or in the engine bay. Anyways, I had purchased some GM knock sensors to swap in once I had the time (currently replacing rod bearings on my daily) but in pursuit to find my knock sensor issue I made a temporary sensor mount and mounted it to the front of the intake. I then made a little sub-harness to run from EB1 to the GM sensors. Test drove my Runner and still get the P0325... ugh... But, that also eliminates the valley harness (only a few months old anyways) and the factory sensors. So, I think in the morning before my drive to work I may swap the Black and Gray knock sensor wires and see if the code jumps to the other bank.
 
1 - 5 of 5 Posts
Top