Toyota Tacoma Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
648 Posts
Discussion Starter #1
Yup a "Catalyst System Efficiency Below Threshold" P0420. I'm on 32,000 miles on my truck and out of the blue i get this code.I have a test pipe, but I haven't thrown a code for 20,000 miles. Well first off i check if there were any exhaust leaks, but seems fine. So my next assumption would to test the o2 sensor. How would i test that? Oh yeah I rested the light, but it came back after a week. Any other ideas would be great!

thanks,

navy
 

·
slow poke
Joined
·
3,098 Posts
You've got a test pipe, your check engine light is doing its job. This is why URD and other companies sell "o2 simulators" (for people who run test pipes)
 

·
Registered
Joined
·
14,486 Posts

·
Registered
Joined
·
70 Posts
I had that code repeatedly come on, and I just shut it off every time. And now it hasnt been on in almost a year.

In my case, I was going to replace the O2 sensors but never had too in the end.
 

·
Registered
Joined
·
220 Posts
If your throwing a P0420 code with a test pipe then the ECU is doing its job.

Now if you have a CAT installed and have that code,, you will need a new cat converter, now for the 3.4L guys just get the first cat converter, those with the 4 cyl, you gotta get both .
 

·
Registered
Joined
·
67 Posts
check out my thread i got the same code and this is what the dealership is doing about it it was code p0430 "WARRENTY WORK AT 29103 MILES

SORRY I DONT KNOW HOW TO MAKE QUICK LINKS
 

·
Registered
Joined
·
220 Posts
gixxertaco said:
check out my thread i got the same code and this is what the dealership is doing about it it was code p0430 "WARRENTY WORK AT 29103 MILES

SORRY I DONT KNOW HOW TO MAKE QUICK LINKS
yea but he has a test pipe so no warranty there :)
 
1 - 9 of 9 Posts
Top