Toyota Tacoma Forum banner

1 - 13 of 13 Posts

·
free JDM'ized
Joined
·
3,397 Posts
Discussion Starter #1
sup guys! recently my girl noticed the ebrake light turning on and off in the taco. i was wondering if any one has had that problem and wut it could be. im hopin i can fix it myself so any help would be greatly appreciated:cool:
 

·
Premium Member
Joined
·
1,747 Posts
rossk35 said:
check the pads first. if there fine add fluid
ha ha ha, do you wipe your ass before you take a **** too? :looney:

i could never understand why someone would do the hard part first, instead of the easiest (and obvious) solution :brickknoc
 

·
free JDM'ized
Joined
·
3,397 Posts
Discussion Starter #5
blown01-s-runner said:
ha ha ha, do you wipe your ass before you take a **** too? :looney:

i could never understand why someone would do the hard part first, instead of the easiest (and obvious) solution :brickknoc
:funnyup: hes just tryin to help lol. thanx fellas ill check the fluid when my girl gets home:clapping:
 

·
Registered
Joined
·
21 Posts
This may sound stupid,but in my 98 Tacoma the light comes on everytime I release the brake handle. There is a switch under the dash that the handle is supposed to deactivate. On the handle there is a tang that is supposed to push the switch in to turn off the light. Pust your handle and turn it to make sure the tang is making contact. Worth a look anyways.
 

·
Premium Member
Joined
·
1,747 Posts
Bignastytoyota said:
This may sound stupid,but in my 98 Tacoma the light comes on everytime I release the brake handle. There is a switch under the dash that the handle is supposed to deactivate. On the handle there is a tang that is supposed to push the switch in to turn off the light. Pust your handle and turn it to make sure the tang is making contact. Worth a look anyways.
 

·
free JDM'ized
Joined
·
3,397 Posts
Discussion Starter #9
:funnyup: a good dose of tang always does the trick ahaha. yeah so i topped the brake fluid today, my girl went to the gym and *drumroll* the light is off. so far so good she ll check again tomorrow cuz it also comes on when the truck is cold. thanx a sh*tload fellas:waytogo:
 

·
Registered
Joined
·
952 Posts
It's the fluid or most likely that the switch under the dash is not being deactivated (pushed in) when you e-brake is in the release position. It could possibly be from the worn out. I had this problem too.

-Paul :waytogo:

PS: Try using the search forum.
 

·
Registered
Joined
·
45 Posts
I had the same problem with my 99 taco.... I had the rear brakes cleaned and adjusted and the brake light went away.

Like others have said... check your brake fluid first.!

:waytogo:
 
1 - 13 of 13 Posts
Top