Toyota Tacoma Forum banner

1 - 6 of 6 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Have any of you installed the DJM drop arms on a 2001??? If so do they fit WELL or are they a sloppy fit .. i cant remember if toyota changed the front control arm design this year .... thanks for any input .....

Justin
 

·
Premium Member
Joined
·
1,288 Posts
They are the same as the previous model years...
as said in a previous forum, one or two of the balljoint bolt holes will need to be reamed out a bit in order for it to fit right... that's pretty much a common flaw, but no big deal.
 

·
Registered
Joined
·
149 Posts
The only problem I had other than the wholes not lining up was side to side movement of the control arm when remounted to the truck. It's only moves about a 1/4" but it makes an annoying clunk when you turn. I called DJM and they said maybe I didn't install it right so I took it to custom truck shop and had them look it over and they said I installed everything right but for some reason there is a gap between the bolt and the urethane bushing that mounts the control arm to the control arm mounting shaft. Mine is a 2001 and I was also under the impression that the arms were the same as previous years, so either I got some defective arms or the 2001 arms are a slight bit wider. I really don't know. Hey maniac, what do you think? Could I have gotten some funky arms?
 

·
Premium Member
Joined
·
1,288 Posts
Well... I dunno.
A buddy of mine with a '01 has the kit and he's never had any trouble as far as I know.
It could be a couple of things... and I'm not going to criticize you and say that you may have installed it wrong, because I'm sure you did it right... I suppose it is possible you could have gotten some bad parts, or maybe the '01's are different... hmm.
It almost sounds like you could have some custom spacers made to fill up the gap - at least to get rid of the "clink" noise.
 

·
Registered
Joined
·
282 Posts
rainman, yeah my passenger side arm does that too about 1/4" of gap. It's the sleeve thats just a tad too small, if it was longer it'd touch the bushing and make it all solid. But i dunno, the knocking sound stopped after like 7k miles : ).
 

·
Registered
Joined
·
149 Posts
Thanks for the response guy's. I am glad to know that I'm not the only one with the problem. Someday I'll tear it apart and fix it, then I'll let you know.
 
1 - 6 of 6 Posts
Top