Toyota Tacoma Forum banner

compressor problems?

1999 Views 12 Replies 10 Participants Last post by  cantucki
compressors not turning on when i start up my truck? checked the fuses and wiring everything is good. what else could be the problem?:confused:
1 - 13 of 13 Posts
Compressors? I'm guessing air suspension compressors. usually they're controlled through the pressure switch. What type of pressure switch do you have?
This guy come with his bagged truck that no one has seen lol ... U just became the beat friend of half the 05minis on this site lol
This guy come with his bagged truck that no one has seen lol ... U just became the beat friend of half the 05minis on this site lol
ive seen it before :shrug:
that should mean they are completely full of air.
if not check your grounds and your pressure switch
nah i dont think its the pressure switch i just changed that a couple months ago but its viair 90 on 120 off and my compressors are the 480c there like 2 years old.
If you have another pressure switch, put that one on and see if the comps are working in general. also helps narrow down the possibilities. How do you have the set-up wired? Are the compressors to a rocker switch? ignition? How are the relays?
Have you checked the relay/solonoid for the compressor?
If you have another pressure switch, put that one on and see if the comps are working in general. also helps narrow down the possibilities. How do you have the set-up wired? Are the compressors to a rocker switch? ignition? How are the relays?
Screw that. Skip the pressure switch and the relays. Wire direct and see if the compressors come on, if they do, that's not it. Then connect your wires to your pressure switch bypassing your relays. If that works then it's the relays.

One of the reasons I skipped a pressure switch and threw a gauge on the tank. Turned on both my compressors w/ a switch instead.
Screw that. Skip the pressure switch and the relays. Wire direct and see if the compressors come on, if they do, that's not it. Then connect your wires to your pressure switch bypassing your relays. If that works then it's the relays.

One of the reasons I skipped a pressure switch and threw a gauge on the tank. Turned on both my compressors w/ a switch instead.
that's how I have mine. although I used a ****ty Radio Shack rocker switch which blew out on me. :mad:
i vote relay. i've had one die on me before.
I have also burnt up a thomas compressor by hooking it up straight to the battery to test it. So be careful. Or it could be that IMO Viairs are junk.
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top