Toyota Tacoma Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter #1
I just go my wheels and tires this week, mounted and balanced by the place I bought them from. I got American Racing Mojaves with Nitto Terra Grapplers. Someone just informed me that I may have a problem if they were not balaced using the lug-centric method. So I gave a call to where I bought them and asked how they were balanced, and sure enough, they were balanced using the hub-centric. Is this going to be a problem? Do I need to get them re-balanced? Please let me know. Thanks.
 

·
Registered
Joined
·
213 Posts
Discussion Starter #3
Blayzirell said:
Are you having any vibrations?

If you are not having any problems, you should be fine.

Take it back ASAP if you do have any issues and make sure they use the Haweka adapter or similar. :waytogo:
They are not on my truck yet. I am getting it lifted and wheels installed next friday. So should I not worry about it till they are on my truck?
 

·
Registered
Joined
·
110 Posts
Ohhhh...

Most likely you will have some type of issue due to the size of the tire.

It's up to you, you can wait and see if you have any problems. Or, you can go right now and get them re-balanced so you don't have to worry about it later.


Just make sure they have a Haweka adapter or something similar, if not pay the extra money and get it done somewhere where they do have the adapter.

I bought my wheels and tires from America's Tire and I did not let them mount or balance my setup. I took it to a high end custom shop and they did it for $100. Came out perfect in one shot!
 
1 - 4 of 4 Posts
Top