Engine dies, no idle unless pressing gas - Runs smooth and NO CODES.... - CustomTacos.com Forum
Go Back   CustomTacos.com Forum > The Garage > Maintenance > 1995.5 - 2004

CustomTacos.com is the premier Toyota Tacoma Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 12-23-2012, 10:03 AM   #1
George4drV6
Grand Tacoholic
 
George4drV6's Avatar
 
Join Date: Oct 2003
Location: NORCAL
Tacoma: 2001 4 door V6 SR5
Posts: 3,708
Default Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

Hey Taco brethren. Long tim no post

Truck has been running smooth until last night I pull up to a stop light on my way home and the engine just dies as I come to a stop. It will not start at all unless I am pressing the gas. When I DO press the gas it starts up and runs just fine until I pull my foot off the gas.

I am not getting any codes and it idles completely smooth when I am holding the gas pedal and even let it down to 600 rpm or so.

I am thinking this is an IAC issue and/or bad EGR but this is a complete binary issue (running or dead) as it's never had a bad idle or stalling issues before even now there is no idle unless Im pushing down on the gas.

Let me know your thoughts.

2001 Tacoma 3.4 Auto
130k miles
At 95k I did plugs and wires
At 115k I did new timing belt and fuel filter
George4drV6 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-23-2012, 10:53 AM   #2
SDRD
Addict
 
SDRD's Avatar
 
Join Date: Nov 2005
Location: Escondido, CA
Tacoma: 2002 Toyota Tacoma sr5 xtra cab
Posts: 611
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

You can remove the IAC from the throttle body and clean it just make sure you get a new IAC gasket and throttle body gasket. You should be able to take apart valve itself (electric motor and mechanical valve)


I found the best way to clean all te carbon in it without damaging it is soaking the mechanical part in ATF for a few hours then a little brake clean just to clean of the ATF

I have seen some fail out of no where so without codes it's an easy place to start

Also check your throttle position sensor. There should be a procedure to test it with a volt meter
__________________
Follow us at:
https://www.facebook.com/OurToyotaTendencies
Instagram: @ourtoyotatendencies

Last edited by SDRD; 12-23-2012 at 10:56 AM. Reason: More info
SDRD is offline   Reply With Quote Quick reply to this message
Old 12-23-2012, 11:13 AM   #3
Enola Gaia
Mambeau / Admin
 
Enola Gaia's Avatar
 
Join Date: Dec 2003
Location: Off the map
Tacoma: '04 SR ('Mamba'); '01 *DC*SR
Posts: 45,021
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

If you weren't having idle issues prior to the engine dying last night, I'd definitely include the throttle position sensor as a possible culprit.
__________________
"If i saw a old dude with what appeared to be a cat over his mouth driving faster than me I'd stop driving fast." - Firdaddy
Line-X, ARE, Recaro, Team Voodoo, Husky, Lund, Optima, OMP, Aesthetic Finishers Inc.,Michelin
Enola Gaia is offline   Reply With Quote Quick reply to this message
Old 12-25-2012, 02:02 PM   #4
George4drV6
Grand Tacoholic
 
George4drV6's Avatar
 
Join Date: Oct 2003
Location: NORCAL
Tacoma: 2001 4 door V6 SR5
Posts: 3,708
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

Huge help guys. I'll be doing this work tomorrow and report back.
George4drV6 is offline   Reply With Quote Quick reply to this message
Old 12-28-2012, 05:06 PM   #5
George4drV6
Grand Tacoholic
 
George4drV6's Avatar
 
Join Date: Oct 2003
Location: NORCAL
Tacoma: 2001 4 door V6 SR5
Posts: 3,708
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

Truck is FIXED. Not 100% sure of the exact issue but I did the following.

1) Completely cleaned out the IAC valve. It was very dirty, gummed up and scrubbed with chem tool carb cleaner and a tooth brush.

2) Replaced the Throttle Positioning Sensor. I figured I might as well change this out when I had the Throttle Body pulled off.

3) Cleaned out the throttle body and butterfly

Cleaned MAF, changed airfilter, and cleaned out the airbox and intake tube just for fun as well.

Starts and idles very smooth now so it seems the issue is completely fixed.

Thanks guys.
George4drV6 is offline   Reply With Quote Quick reply to this message
Old 12-28-2012, 06:05 PM   #6
Enola Gaia
Mambeau / Admin
 
Enola Gaia's Avatar
 
Join Date: Dec 2003
Location: Off the map
Tacoma: '04 SR ('Mamba'); '01 *DC*SR
Posts: 45,021
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

Glad you got it resolved ...
__________________
"If i saw a old dude with what appeared to be a cat over his mouth driving faster than me I'd stop driving fast." - Firdaddy
Line-X, ARE, Recaro, Team Voodoo, Husky, Lund, Optima, OMP, Aesthetic Finishers Inc.,Michelin
Enola Gaia is offline   Reply With Quote Quick reply to this message
Old 12-29-2012, 12:01 PM   #7
tacomatic1
Grand Tacoholic
 
tacomatic1's Avatar
 
Join Date: Jul 2005
Location: Palm Coast, Florida
Tacoma: 1998 Automatic 2rz xtracab, 1999 5spd 2rz regcab
Posts: 3,033
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

I bet your IAC was sticking, and not allowing for sufficient air to make it into the motor for it to idle. This would make sense why your motor would only run when you opened the throttle plate.
tacomatic1 is offline   Reply With Quote Quick reply to this message
Old 01-16-2013, 10:09 AM   #8
ENOSHbeatpuppet
Enthusiast
 
ENOSHbeatpuppet's Avatar
 
Join Date: Jul 2002
Location: San Diego, CA
Tacoma: '96 Tacoma
Posts: 232
Default Re: Engine dies, no idle unless pressing gas - Runs smooth and NO CODES....

Yup, my roommate's 2002 Tacoma was doing the same... dying out soon after start because it wouldn't hold idle unless you gave it some gas. Took apart his TB and IAC and cleaned it out. Starts up nicely and idles smooth now.

Took only a couple hours... so decided I should and need to clean mine out, opened up my 1996 2.4L Tacoma. 16+ years - Oh man was this long overdue.

Now she purrs like a cat.

(If you love your truck, don't let your TB or IAC get this dirty)
Attached Images
File Type: jpg TB_1996_Tacoma.jpg (48.2 KB, 21 views)
File Type: jpg IAC_1996_Tacoma.jpg (48.0 KB, 21 views)
__________________

crevicecreeps.com
ENOSHbeatpuppet is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the CustomTacos.com Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5vzfe erratic Idle when hot then dies, Hard cranking. goodoldjam 1995.5 - 2004 1 05-12-2012 07:47 PM
rough idle but runs great Tacosurf 1995.5 - 2004 25 07-26-2010 05:03 PM
Engine dies on start up. Anyone? Ad@m 1995.5 - 2004 8 01-25-2007 11:18 PM
Engine codes/ color codes for every toyota ever made? LigerQ4 Performance 1 12-26-2006 04:21 PM
I pulled codes... need help with idle control system ochizon Performance 3 10-18-2003 10:03 PM


All times are GMT -6. The time now is 07:32 AM.



© Copyright 2001-2008 CustomTacos.com. CustomTacos.com is privately owned and is in no way affiliated with Toyota Motor Corporation.
Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide