Another code, p0300, and p0303. Need help, what should i do next? - Toyota Tacoma Forum
User Tag List

Reply
 
Thread Tools Display Modes
#1 (permalink) Old 08-12-2007, 11:17 PM
Member
 
Join Date: Aug 2007
Location: atwater, cali.
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Another code, p0300, and p0303. Need help, what should i do next?

I think i've researched just about every thread on here but thought i should still post. Here's what i got:
p0303-misfire, #3 cylander.
p0300-random misire.
98 tac. 2.7 4x4, all stock.
265,000 miles, but runs like a champ. Doesnt burn a drop of oil
Maintained religously.
Trucks been perfect but about a month ago i noticed it kind of started idleing just a tad rough. Passengers never noticed it but i did. Than all of a sudden it throws the codes mentioned above. Just had the battery changed because a guy at walmart said i needed a battery because the truck took about 1.5 seconds to start after turning the ignition. Changed, started exactly the same. So i started working on the check engine light. This is what i have so far.
Changed the oil, spark plugs, wires and thought the coil might be throwing the code, changed it, not it.
Every fluid has always been changed. Radiator, perfectly clear green. Gas filter changed 1.5 years ago.
No visible smoke coming out of the exhaust, but the pipe does have carbon build up.
Spark plugs have a light kind of a brownish tint on parts of them now, changed about two weeks ago. Thats normal right? NGK plugs that are recommended in the hanes manuel. Gapped according to hanes manual. THe ones prior were sorry bosh's that the truck ate up pretty good. I installed them last summer but i do commute. Probably put about 25,000 miles on them.
After all this, cleared the code again, and it came back next day.
On the bad side:
I decided to check the air filter, dusty as hell. Am going to buy one tomorrow. I cleared most of the dust off and put it back in and cleared the code. Just curious, drove it, light came on after about 10 min.s. I've never ran a cleaner through it or taken it into toyota or anybody for any type of services. I do them myself. The motor has never been opened up and always ran perfect. The only things that have been changed that havent been mentioned are the starter. This week i am going to run sea foam through it,gas,pvc tube and booster cable hose. After this, i just dont know what else to do? Any insights before i move onto the fuel injectors and motor????????????

Last edited by jaime7818; 08-12-2007 at 11:24 PM.
jaime7818 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-12-2007, 11:20 PM
Member
 
Join Date: Aug 2007
Location: atwater, cali.
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: Another code, p0300, and p0303. Need help, what should i do next?

And i did check all the vacuum lines, looked fine. Cleaned out the throttle body with a cleaner spray. Half assed it but did idle a tad better.
jaime7818 is offline  
#3 (permalink) Old 08-12-2007, 11:50 PM
Veteran
 
Join Date: Sep 2006
Location: Seattle
Posts: 499
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Another code, p0300, and p0303. Need help, what should i do next?

Quote:
Originally Posted by jaime7818 View Post
And i did check all the vacuum lines, looked fine. Cleaned out the throttle body with a cleaner spray. Half assed it but did idle a tad better.

Check the plugs, wires, distributor. Cylinder 3 specifically.

1996 5VZFE 4x4 STS Turbo-ing!
VF'N8 is offline  
#4 (permalink) Old 08-13-2007, 06:14 AM
Addict
 
xsvtoyz's Avatar
 
Join Date: Apr 2007
Location: Oklahoma
Posts: 926
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Another code, p0300, and p0303. Need help, what should i do next?

did you get some electrical parts cleaner and clean the MAF?
I get those codes for all my cylinders when I idle the truck too long but I attribute that to the cams I put in. They make my truck idle at 620 rpm.

Supercharged Cammed Header 3rz!
xsvtoyz is offline  
#5 (permalink) Old 08-13-2007, 09:18 AM
Member
 
Join Date: Aug 2007
Location: atwater, cali.
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: Another code, p0300, and p0303. Need help, what should i do next?

I did clean the air mass sensor with electrical cleaner about two years ago. I forgot i changed the o2 sensor about 2 years ago and catalytic converter last spring. I'll clean the AMS, when i cleaned up the Throttle body some, the AMS looked fine though.....Thanks guys.
jaime7818 is offline  
#6 (permalink) Old 08-13-2007, 09:58 AM
Tacoholic
 
TahoesHateMe's Avatar
 
Join Date: Jul 2006
Location: Torrance, SoCal
Posts: 1,041
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Another code, p0300, and p0303. Need help, what should i do next?

You changed the battery because it took 1.5 seconds to start



Before you go wasting anymore time and money. Do a compression check. You could keep throwing money at it but never fix it if its got a burnt valve.

WWW.Ti2TT.com WWW.ASVinventions.com WWW.Socal-Sportbikes.com WWW.LAcarGUY.com
Made my own CAI, TRD s/s, Stoptech BBK, DTLT Headers, Urd cat back, maf Calibrator, BHLM, 5000k Bi xenon HIDs and HIDs in the fogs, Kenwood headunit with Sirius Radio.
TahoesHateMe is offline  
#7 (permalink) Old 08-13-2007, 10:06 AM
Addict
 
chipsndukes's Avatar
 
Join Date: May 2007
Location: Detroit, MI
Posts: 816
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Another code, p0300, and p0303. Need help, what should i do next?

Did you try resetting the code?
Unplug the battery for a few hours or buy an OBD II scanner and press reset.
I don't know if you did this, if not, sorry.
Chipsndukes

***edit*** forget the above, once again not paying attention before answering.

Anyhow:

Does anyone know what criteria the engine computer uses to set this code? Have insight into the ECU?
I assume it is looking primarily at the electric side, nothing with fuel can be monitored because the O2 sensor is a path with all cylinders, couldn't check specific cylinders.

Therefore assume it's pulling an electrical fault in the ignition, or like jaime is saying maybe an electrical with the injector.

Jaime, try swapping injectors back and forth. I believe this is possible without removing any part of the intake, you just have to loosen the two fuel rail retaining bolts and pull the assembly up, be careful where the injector tips end up sticking into. (I BELIEVE this is possible, maybe you have to take off the TB).

you may want to bleed fuel pressure first, you can do this with the banjo bolt on the rail and a rag (my method) or run the engine and unplug the fuel pump relay (buried under dash) the elegant method.

Maybe this will do something. If you have plenty of time and don't mind smelling like fuel for a while you might try this.

Chipsndukes

PS, I assume you know just CAREFULLY pull the injector out from the bottom, maybe number 'em, push it back in in another cylinder and see if you still get that fault.

Did you try rerouting the spark plug wires or isolating them from any ground source? (I know they're brand new, but this would really eliminate them as a possibility, is the most obvious cause from the outset.


Last edited by chipsndukes; 08-13-2007 at 10:18 AM.
chipsndukes is offline  
#8 (permalink) Old 08-13-2007, 11:14 PM
Member
 
Join Date: Aug 2007
Location: atwater, cali.
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: Another code, p0300, and p0303. Need help, what should i do next?

Im on it. I'll get back to you guys as soon as i get to the next stage. I just ran seafoam. We'll see tomorrow. Oh, and by the way, the reason i changed the battery was because it was atleast 8 years old. Figured, hey what the heck, im going deer hunting in the fall, cant risk getting stuck up there. I just thought i would mention it to rule it out..................................
jaime7818 is offline  
#9 (permalink) Old 08-13-2007, 11:56 PM
Member
 
unclezesta's Avatar
 
Join Date: Jul 2007
Location: Moorpark, California
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Re: Another code, p0300, and p0303. Need help, what should i do next?

oh good. i was just about to fall off my chair after hearing that you took advice from a walmart automotive employee.
unclezesta is offline  
#10 (permalink) Old 08-14-2007, 12:27 AM
Boost Addict
 
Spyder327's Avatar
 
Join Date: Jul 2006
Location: Phoenix, AZ
Posts: 712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Another code, p0300, and p0303. Need help, what should i do next?

DTC P0303 Cylinder No. 3 Misfire Detected

CIRCUIT DESCRIPTION
Misfire: The ECM uses the crankshaft position sensor and camshaft position sensor to monitor changes in the crankshaft rotation for each cylinder The ECM counts the number of times the engine speed change rate indicates that misfire has occurred. And when the misfire rate equals or exceeds the count indicating that the engine condition has deteriorated, the MIL lights up.
If the misfire rate is high enough and the driving conditions will cause catalyst overheating, the MIL blinks when misfiring occurs.



DETECTING CONDITION
When the 2 or more codes for a misfiring cylinder are recorded repeatedly but no random misfire code is recorded, it indicates that the misfires were detected and recorded at different times.












Spyder327 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Toyota Tacoma Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome