really rough idle? - Toyota Tacoma Forum
User Tag List

Reply
 
Thread Tools Display Modes
#1 (permalink) Old 11-07-2005, 12:26 AM
Member
 
Join Date: May 2004
Location: Virginia Beach, VA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
really rough idle?

i have a 96 2.4L taco. As of right now...it's acting up! My idle is extremely rough. So rough that the entire truck shakes. I have an aftermarket exhaust so it even sounds really bad. when i start my truck there's a loud clicking sound coming from the back of the engine. It goes away after i hit about 40 mph. There's also a strange smell. Hard to tell where it's coming from...the actual engine or exhaust fumes. My check engine light flashes when i drive it. I haven't changed the timing chain yet. It has over 150000 miles already. Could that be the problem? i'm really confused about what it is. I wanna take it to the shop tomorrow but i don't wanna get ripped off and pay an arm and a leg.
HELP! any info or suggestions would be grateful.
streetaco96 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-07-2005, 05:17 AM
back in black (tacoma)!
 
Join Date: Nov 2002
Location: Miami, FL
Posts: 6,235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

you are misfiring. Check the code, see what cylinder is misfiring, and check the spark plug. It could be as simple as a fouled plug. Then do a compression test. It could be a blown headgasket.

Are you noticing a lack of performance, like it really doesnt want to go at all?
ochizon is offline  
#3 (permalink) Old 11-07-2005, 07:38 AM
Grand Tacoholic
 
Firdaddy's Avatar
 
Join Date: Dec 2003
Location: Dickinson TX
Posts: 14,439
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

i agree with alex, also could be your cat .. well i dunno, the flashing c/e light is defintally a misfire
Firdaddy is offline  
#4 (permalink) Old 11-07-2005, 11:51 AM
Tacoholic
 
Jarrett_B's Avatar
 
Join Date: Mar 2004
Location: Los Alamitos, California
Posts: 1,445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

i have a rough idle at occasional startup, its really low, but i haven't seen a check engine light, it starts up and idles really really low, the point of stalling, any idea of whats happening

this just started saturday when i was wheeling
Jarrett_B is offline  
#5 (permalink) Old 11-07-2005, 01:36 PM
Grand Tacoholic
 
Firdaddy's Avatar
 
Join Date: Dec 2003
Location: Dickinson TX
Posts: 14,439
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

i'd check for any vaccum leak in your rig, mabey somethign was jarred off when wheeling..
Firdaddy is offline  
#6 (permalink) Old 11-07-2005, 03:01 PM
Member
 
Join Date: May 2004
Location: Virginia Beach, VA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: really rough idle?

yeah...my truck is definately lagging. It barely wants to move.
streetaco96 is offline  
#7 (permalink) Old 11-07-2005, 03:27 PM
Enthusiast
 
01TACOMA SD's Avatar
 
Join Date: Aug 2004
Location: San Diego, Ca
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

I had a similar problem. Started my truck one morning and the idle was louder than usual. As I was driving to work the check engine light went on. Took it to Toyota Dealership and my 02 sensor gone bad. Bought a new 02 sensor and replaced it myself. Unplugged the battery to reset and remove the check engine light. rough idle was gone and also check engine light there after.
01TACOMA SD is offline  
#8 (permalink) Old 11-07-2005, 04:04 PM
Grand Tacoholic
 
Firdaddy's Avatar
 
Join Date: Dec 2003
Location: Dickinson TX
Posts: 14,439
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

Quote:
yeah...my truck is definately lagging. It barely wants to move.
i'd defintally bet my money on the cat go dump the exhaust and see if the symptons presist.. althoght it might get worse since the lack of backpresure does that bad idle too...
Firdaddy is offline  
#9 (permalink) Old 11-08-2005, 05:24 AM
back in black (tacoma)!
 
Join Date: Nov 2002
Location: Miami, FL
Posts: 6,235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: really rough idle?

Quote:
My check engine light flashes when i drive it.
Before we talk any more about catalytic converters, lets clear this up: THE FLASHING LIGHT INDICATES A MISFIRE. The lack of power is because 1 or more cylinders are not firing. GET THE CODE CHECKED, then get back to us.

Stop driving it, too!
ochizon is offline  
#10 (permalink) Old 11-11-2005, 12:16 AM
Member
 
Join Date: May 2004
Location: Virginia Beach, VA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: really rough idle?

I may sound like an idiot but when you say "check the code" you mean? and how would i go about doing it? I'm a beginner when it comes to certain issues pertaining to cars.
streetaco96 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Toyota Tacoma Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome